Aller au contenu

Résoudre les problèmes de LogAnalyzer 1.13 et php 8.2

Environnement

Système d’exploitation : Debian 12

Version de php : 8.2

Version de Log Analyzer : 4.1.13

Problème détecté

Après l’installation de Log Analyzer, on peut rencontrer quelques soucis. Le premier et le plus courant étant celui-ci :

« Could not find the configured table, maybe misspelled or the tablenames are case sensitive« 

Pistes de résolutions (testées et approuvées) :

1. Vérifier la casse de l’info sur la table « SystemEvents » dans le fichier de configuration de LogAnalyzer

sudo nano /var/www/html/loganalyzer/config.php

Chercher la ligne contenant le terme « SystemEvents » (à la fin du fichier) et s’assurer que la casse est respectée :

2. Se connecter à l’admin center dans l’interface web,

Aller dans « sources », cliquer sur « modifier » puis vérifier que la casse est également respectée ici :

A ce stade, il se peut que l’interface fonctionne de nouveau dans son ensemble, sauf pour la page d’index de LogAnalyzer qui peut afficher une page blanche.

Dans ce cas, le bon réflexe est le suivant : activer les rapports d’erreur dans php.ini :

sudo nano /etc/php/8.2/apache2/php.ini

Cherche la ligne « display_errors » et la passer à « On »

Puis relancer apache2

systemctl restart apache2

En rechargeant la page d’accueil de Log Analyzer, le message suivant apparaît : « Fatal error: Uncaught mysqli_sql_exception: Unknown column ‘processid’ in ‘field list’« 

Pour résoudre ce problème, rdv dans Mysql pour ajouter manuellement les colonnes manquantes :

mysql -u root -p
USE Syslog;
ALTER TABLE SystemEvents
ADD COLUMN checksum INT NOT NULL;
ALTER TABLE SystemEvents
ADD COLUMN processid VARCHAR(60) NOT NULL;
exit

Après ça, en rafraichissant la page d’accueil, tout apparait comme il faut :

Sources qui m’ont aidé à résoudre ce souci :

https://github.com/rsyslog/loganalyzer/issues/75